
Overview of Mindful

Welcome and thank you for choosing Mindful.

Mindful combines an event reminder, mini calendar, date calculator* and countdown timer* in an easy to 
use system tray application. Define your own events and/or select from a list of 72 predefined events 
including many US, Canadian and Jewish holidays. Use Mindful to be reminded of appointments, bill 
payments, anniversaries and any occasions, recurring or not, that you never want to miss. 

Events can be simple such as anniversaries, which occur every year on the same day, or formulated such
as a meeting that occurs every 3 months on the last Friday of the month. Mindful supports both simple 
and formulated events. 

The age of a person (or event) can be included in the event description simply by adding the year of birth 
(or original event year) in square brackets into the event name. For example, if you set the name of an 
event to "John's [1967] Birthday", this item will appear as "John's 38th Birthday" in the list of events 
(assuming of course that the current year is 2005 and that John's birthday has not yet passed in the 
current year).

Mindful also supports one-time events that can be deleted automatically once passed or kept for future 
reference, according to your preference. Keeping a one-time event for future reference can be useful to 
remember when was the last time it occurred, such as when you had your last sight test.

With Mindful SE, you can optionally set an alarm for each event. Alarms perform specific actions such as 
displaying a popup window and/or executing another program or Internet shortcut at a precise time on the
day of the event. 

A simple wizard helps you through the creation and modification of events so that you don't have to 
remember all of the possible options when you create or modify them.

When your list of events is refreshed (i.e. when the program starts or at the beginning of a new day), the 
most current event is automatically selected as the first visible item in the list. In order to make it easier to 
identify events of interest, items in your list of events are color-coded according to their point in time. By 
default past events appear in blue, current day events appear in bold red, events due for notice appear in
orange, and other future events appear in green. 

With Mindful SE, you can prevent recurring events from rolling forward automatically each time your list of
events is refreshed, until you have acknowledged that it is acceptable to do so (i.e. cleared the event*). 
This is useful if you have some events that you don’t want to roll forward until you have performed a 
certain task. For example, you may want to make sure you haven’t forgotten to pay a bill before your 
monthly bill reminder is rolled forward to the next month, even if the date of that event (due date of the 
bill) has already passed. In the same way, one-time events that should be deleted once passed will not be
deleted until they have been cleared either.

With Mindful SE, you can also manually roll forward some events ahead of time. For example, you may 
have created an event for the due date of a monthly bill but you don’t want to see this item at the top of 
your event list once you have sent a payment for that bill, even if the bill due date has not yet passed. By 
manually rolling the event forward to its next occurrence, this item is immediately repositioned further 
down in your event list according to its new occurrence date. 

Mindful loads automatically when you start your computer and then displays your list of events if at least 
one item in the list is due for notice. If no event in your list is due for notice, the program loads minimized. 
When minimized, the program remains in your system tray ready for you to use again whenever you need
it. Positioning the mouse cursor over Mindful’s icon in the system tray will have your next upcoming event
displayed in a hint. Simply left-click Mindful’s icon in the system tray to restore (i.e. display) your list of 



events. 

If you leave your computer on overnight, Mindful updates your list of events automatically in the first 
minute of the new day and shows you a balloon hint** above the system tray to this effect so you can be 
aware of this change the next time that you look at your computer screen.

Getting started
If you are new to Mindful and need to know where to go from here, we suggest that you start by reading 
through the list of features to better understand what Mindful can do for you and then start adding your 
own items to your list of events. The How to… section in the table of contents contains a list of topics that 
explain in detail almost everything you can do with Mindful.

For detailed information on the various program options and controls, please consult the Reference 
section in the table of contents.

Thank you for choosing Mindful.
----
Team Felitec

* Option available in the Special Edition only.
**This balloon hint is displayed under Windows 2000 and XP only.



Mindful versus Mindful SE (Special Edition)

There are 2 editions of Mindful; the standard edition simply referred to as Mindful (freeware version) and 
the Special Edition referred to as Mindful SE. The standard edition is free for anyone to use but has fewer
features than the Special Edition, which requires a low one-time fee to use but provides many more 
features. Following is an overview of the features you get in each edition. Each feature is explained in 
greater detail in the List of Features.

Feature Mindful Mindful SE
User-defined events Unlimited Unlimited
Predefined events 72 72
Event age calculator Yes Yes
Event alarms - Yes
Event notes Yes Yes
Manual roll forward - Yes
Roll forward clearance - Yes
Color-coded events Hard-coded Customizable
Distinct user file Yes Yes
Mini calendar Yes Yes
Date calculator - Yes
Countdown timer - Yes



List of Features

Following is a list of the main features of Mindful with a brief explanation of each of them. Some features 
are found in both editions of Mindful (Mindful and Mindful SE) while others are found in the Special Edition
(Mindful SE) only. Features found only in Mindful SE are identified with the words ‘Special Edition’ in 
brackets after the feature name.

User-defined events
A user-defined event is simply an event that you define yourself like: the anniversary of a friend, an 
appointment with your doctor, or the time to pay your rent. The number of events you can define with 
Mindful is only limited by the size of your computer’s memory. In theory, you should be able to define as 
many events as you like. 

The events that you define yourself can be simple, like anniversaries that occur on the same date every 
year, or formulated, such as a meeting that occurs on the last Friday of the month every three months. 
Mindful supports both simple and formulated events.

Each event (user-defined or not) has a number of options that you can set while creating or modifying the 
event. For example, you can preset the number of days at which you want to be notified that an event is 
coming, or whether or not a one-time event should be deleted once passed. For more information about 
events in general and the options you can set for each of them, see the help topic about events.

Predefined events
Mindful also provides a list of 72 predefined events including many US, Canadian and Jewish holidays. 
However, you won’t be reminded of all these events automatically just because they are supported by the
program. You need to select the predefined events of which you want to be reminded to include them in 
your own list of events for Mindful to remind you of these events. 

Predefined events also have a number of options that you can set while adding them to your list of 
events. For more information about events in general and the options you can set for each of them, see 
the help topic about events.

Event age calculator
The age of a person (or event) can be calculated automatically and included in the event description 
simply by adding the year of birth (or original event year) in square brackets into the event name.

For example, if you set the name of an event to "John's [1967] Birthday", the event will appear as "John's 
38th Birthday" in the list of events (assuming that the current year is 2005 and that John's birthday has 
not yet passed in the current year of course).

Event alarms (Special Edition)
Event alarms go one step further in notifying you of events. By setting an alarm for an event, you can 
have an action performed at a precise time on the day the event occurs. Possible actions include 
displaying a popup window with (or without) a countdown timer for a preset number of minutes, executing 
a file, or executing an Internet link. A sound is also played when the alarm goes off and when the 
countdown timer reaches zero. For more information about alarms and how to use them, please see 
About Alarms and Setting / Removing Event Alarms.

Event notes
Each event can have notes attached to it. These notes can be useful to remind you of some additional 
information about an event that is not part of the event name itself. For example, the notes field for the 
anniversary of a friend can contain their mailing address so you can mail them a birthday card.

Manual roll forward (Special Edition)
By default, event dates are rolled forward to their next occurrence each time an occurrence is passed. 



The manual roll forward feature allows you to force the date of a user-defined event to roll forward ahead 
of time. 

For example, you may have created an event for the due date of a monthly bill but you don’t want to see 
this event at the top of your list once you have sent a payment for that bill, even if the bill due date has not
yet passed. By forcing the event to its next occurrence, this item is immediately repositioned further down 
in your event list according to its new occurrence date.

NOTE: The manual roll forward feature is available for user-defined events only. Also, an event must be 
cleared before it can be rolled forward.

Roll forward clearance (Special Edition)
A roll forward clearance is a confirmation that allows Mindful to change the date of an event to its next 
occurrence. This feature is very handy if you need to confirm that you completed a certain task before an 
event date is rolled forward to its next occurrence. For example, you may want to confirm that you paid a 
monthly bill before the event for that bill is rolled forward to the next month. In this case, the event will 
continue to appear in your list of events due for notice (even if the actual event date has passed) until you
manually clear the event. For events that don’t require a roll forward clearance, simply check the auto-
clear flag while creating or modifying the event. Cleared events have a checkmark in the list of events.

Color-coded events
All events in Mindful are color-coded according to their point in time. By default, passed events appear in 
blue, current day events appear in bold red, events due for notice appear in orange and other future 
events appear in green in your list of events. If you are using Mindful SE, you can customize the font color
and style of your events according to your preferences.

Distinct user file
By default, your list of events is stored in a file called ‘Mindful.bin’ located in the folder where the software
is installed. With the distinct user file feature, you can select a different folder or file name for storing your 
list of events. This feature has 2 advantages. The first one is that each user account on your computer 
can have its own event file (i.e. you don’t have to share your list of events with other users of your 
computer). The second advantage is that the software can be used in a controlled environment where 
users do not have write access under the Program Files folder, which is where the generic event file is 
stored by default. 

Mini calendar
Mindful includes a mini perpetual calendar that you can consult at any time while the program is running. 
The mini calendar is very handy if you need to consult a calendar from time to time. For more information 
on how to display or use the mini calendar, please see Displaying Mindful  ’  s Mini Calendar  .

Date calculator (Special Edition)
The date calculator in Mindful has two functions. It can calculate the number of days between two dates, 
or calculate a second date by adding a number of days to a first one. For more information on how to use 
the date calculator in Mindful, please see Using Mindful  ’  s Date Calculator  . 

Countdown timer (Special Edition)
Whether you have something to pick up at the front desk in five minutes, your favorite show starts in 10 
minutes or you want to let your eggs boil for three minutes, you can count on this simple utility to help you
make sure you are on time. Simply set the time to countdown, click Start, and let the timer do the rest. A 
progress bar is filled as the time progresses and a sound is played when the timer reaches zero. For 
more information on how to use the countdown timer in Mindful, please see Using Mindful  ’  s Countdown   
Timer.





Starting Mindful

Starting Mindful is done automatically each time your computer starts. However, if you close the program 
and wish to start it again, you don't have to restart your computer to do so. Assuming that you selected 
the default options during the installation, simply select Start -> Programs -> Mindful -> Mindful or double-
click the Mindful icon on your desktop to restart Mindful at any time. 

NOTE: There can only be one instance of the program running at any time for each user. 

See also Closing Mindful



Closing Mindful

There are three ways to close Mindful manually…

Ÿ While Mindful’s main window or one of Mindful’s tools has the focus, press Alt+F4.
Ÿ Select Application -> Exit from Mindful’s main window.
Ÿ Right-click on Mindful’s icon in the system tray and then select Exit from the popup menu.

See also Starting Mindful



Creating Events

There are four ways to add new events to your list of events...

Ÿ Click the Add event button on the event list tool bar.
Ÿ While the list of events has the focus, press the Insert key.
Ÿ Right-click on your list of events and then select New event... from the popup menu.
Ÿ Select Event -> New….

Following any of these actions, the Event Details dialog is displayed. This dialog guides you through each
step in creating a new event. Simply follow the dialog’s instructions to create your new event.

See also Modifying Events, Deleting Events



Modifying Events

There are five ways to modify an event…

Ÿ Double-click the event to be modified in the list.
Ÿ Select the event to be modified and then press Enter while the list of events still has the focus.
Ÿ Select the event in the list and then click the Modify event button on the event list tool bar.
Ÿ Right-click the event to be modified in the list and then select Modify event… from the popup menu.
Ÿ Select the event in the list and then select Event -> Modify…

Following any of these actions, the Event Details dialog is displayed. This dialog guides you through the 
modification process for the event selected. Simply follow the dialog’s instructions to modify the event 
selected.

See also Creating Events, Deleting Events



Deleting Events

You can delete one or more events at a time from the list of events. To do so, select the events to be 
deleted and then do one of the following…

Ÿ Click the Delete selected events button on the event list tool bar.
Ÿ While the list of events has the focus, press the Delete key.
Ÿ Right-click one of the events selected and then select Delete events… from the popup menu.
Ÿ Select Event -> Delete…

Upon performing one of these actions, you will be prompted to confirm your intention to delete the events 
selected. Simply click Yes to proceed and the selected events will be deleted immediately.

See also Creating Events, Modifying Events



Displaying the Details of an Event

To display the details of an event, simply position the mouse cursor over the event in the list of events and
the details of that event will be displayed in a popup hint.



Clearing / Unclearing Events (Special Edition)

When the date of a recurring event has passed, the date is rolled forward to its next occurrence 
automatically unless the event has not been cleared. In the same manner, a one-time event that should 
be deleted automatically once passed will not be deleted until it has been cleared also. Events that have 
been cleared appear with a check mark in the list of events.

Clearing an event can be done automatically or manually. When an event is created or rolled forward to 
its next occurrence, Mindful marks the event as either cleared or non-cleared depending on the auto-clear
flag of that event. If the auto-clear flag is set then the event is cleared automatically, otherwise the event 
is marked as non-cleared and has to be cleared manually before it can be either rolled forward or deleted 
(one-time event) automatically the next time the event date has passed. 

You can manually clear or unclear one or more events at a time by selecting them and then performing 
one of the following actions…

Ÿ While the list of events still has the focus, press the space bar.
Ÿ Click the Clear / Unclear selected events button on the event list tool bar.
Ÿ Right-click one of the events selected and then select Clear / Unclear events from the popup menu.
Ÿ Select Event -> Clear / Unclear.

NOTE: If there are many events selected, the first one determines whether all the ones selected will be 
cleared or uncleared (i.e. if the first event is cleared then all the events selected will be uncleared and vice
versa). 



Rolling an Event Forward (Special Edition)

Normally, the date of an event is rolled forward automatically to its next occurrence each time the event 
passes. However, at times it may be useful to roll forward the date of an event before the current event 
date is passed. For example, you may have created an event for the due date of a monthly bill but don’t 
want to see this event at the top of your list once you’ve sent the bill payment for the current month, even 
if the current due date has not yet passed. By rolling the event forward to its next occurrence, the event 
will automatically be repositioned further down in the list according to its new date.

To roll forward the date of an event manually, simply select the event in the list and do one of the 
following…

Ÿ Click the Roll event forward button on the event list tool bar.
Ÿ Right-click the event and select Roll forward from the popup menu.
Ÿ Select Event -> Roll forward.

NOTE: The manual roll forward feature is available for user-defined events only. Also, an event must have
been cleared before it can be rolled forward.

WARNING: Once you rolled the an event forward manually to its next occurrence, the only way to roll it 
back is by modifying the date of the event manually. Be careful not to click the Roll event forward button 
repetitively for an event unless you really want to roll it forward by many occurrences.



Setting / Removing Event Alarms (Special Edition)

Alarms are set through the Alarm page of the Event Details dialog. This dialog is displayed each time you 
create or edit an event. To set an alarm for an event, do the following…

1. While the Event Details dialog is displayed, click the next button until the Alarm page is displayed.

2. Make sure the Alarm check box contains a check mark and set the time for the alarm to go off.

3. Click Next to display the Alarm Actions page. 

This page gives you 2 choices of actions to be performed when the alarm goes off…

Ÿ Popup Window (with or without a countdown timer)
Ÿ Execute a file or Internet link

4. Check the box of the action(s) you want to be performed when the alarm goes off. You can check 
any of the 2 actions or both, but you must check at least one. 

If you check the Popup window option, you can also set a countdown timer that will start when the 
popup window is displayed. If you don’t want a countdown timer with the popup window, simply 
leave the countdown minutes to zero.



If you check the Execute a file or Internet link… option, you must also provide the name and location 
of the file or Internet link to be executed. You can click the Select file button on the right of the edit 
box to locate and select a file or you can type your entry directly into the edit box. The Test button 
allows you to execute your entry to make sure it can execute without errors.

5. Click Next and continue setting the rest of your event options as usual.

To remove an alarm from an event…

1. Start by editing the event that contains the alarm to be removed.
2. Click Next on the Event Details dialog until you reach the Alarm page.
3. Uncheck the Alarm check box.
4. Click Next again until you reach Confirmation page of the Event Details dialog.
5. Click Finish to confirm your changes.



Displaying Mindful’s Mini Calendar

There are two ways to display the mini calendar in Mindful…

Ÿ From Mindful’s main form, select Tools -> Calendar.
Ÿ Right-click Mindful’s system tray icon and then select Calendar… from the popup menu.

The mini calendar displays one month at a time by default. To display many months at once, simply resize
the mini calendar window. As the size of the calendar window increases, more months are added to it. 
New columns are added as the width of the window increases and new rows are added as the height 
increases. Mindful remembers the height and width of the calendar window when you change them, so 
you don’t have to resize the window again each time it is displayed, even after closing and re-starting the 
program.



Using Mindful’s Date Calculator (Special Edition)

There are two ways to display the date calculator…

Ÿ From Mindful’s main form, select Tools -> Date calculator…
Ÿ Right-click Mindful’s system tray icon and then select Date Calculator… from the popup menu.

The date calculator contains two date fields and one Days field, which represents the number of days 
between these two dates. By changing any of the two dates, the number of days between the two dates is
calculated automatically and the result displayed in the Days field. A negative number in the Days field 
indicates that the second date precedes the first one.

By changing the value of the Days field, the number of days is added to the first date and the second date
is updated automatically with the result. You can also enter a negative number of days to calculate a 
second date that precedes the first one.



Using Mindful’s Countdown Timer (Special Edition)

There are two ways to display the countdown timer…

Ÿ From Mindful’s main form, select Tools -> Countdown timer…
Ÿ Right-click Mindful’s system tray icon and then select Countdown timer… from the popup menu.

The countdown timer is very simple to use. Simply set the time to countdown in hours, minutes and/or 
seconds and click Start. 

There is really not much more to it, the timer will start counting down the time immediately and play a 
sound when it reaches zero. While counting down the time, a progress bar gives you a visual indication of
how much time has passed since the beginning of the countdown and how much time is left until it 
reaches zero. The amount of time left until the timer reaches zero is also indicated in hours, minutes and 
seconds. 

You can pause the timer at any time by clicking the Pause button while the timer is running. When the 
timer is paused, you can restart it by clicking the Start button again, and the timer will resume from where 
it left off. 

When the timer is running or paused, the hours, minutes and seconds input boxes are disabled. Click the 
Stop button to stop the timer and allow these fields to be changed again.

The sound that is played when the timer reaches zero can be changed through the Application 
Preferences dialog. 

TIP: If you want the countdown timer to stay on top of other windows, run it from the system tray icon 
while your event list remains minimized.



Backing up your Event File

Mindful itself does not make any backup of your event file. If you want to backup your event file, which is 
highly recommended to do on a regular basis, you should do it the same way you backup any other 
important files on your computer. 

By default, the event file is called Mindful.bin and is located in the folder where Mindful was installed. 
Unless you have changed the location and/or name of your event file, this is where you will find it. 
Otherwise, you can select File -> Save As… to see the current name and location of your event file.

WARNING: By default, the changes you make to your list of events are saved only when the program 
closes or the event list is minimized. Before taking a backup of your event file, it is recommended to select
File -> Save or minimize your list of events if you have done any recent changes to it, otherwise the event
file may not include your most recent changes at the time of doing the backup.

See also The Event File, Renaming your Event File



Renaming your Event File

By default, after the original installation of Mindful, your event file is named Mindful.bin and is located in 
the folder where Mindful was installed. However, you can save your event file under a different name 
and/or in a different location. 

To change the name/location of your event file, do the following…

1. Select File -> Save As… to display the Save As dialog.
2. Select the name and location where you want your event file to be saved.
3. Click Save to save your event file under its new name and/or location.

NOTE: If you select a file that already exists in the Save As dialog, Mindful will prompt you confirm before 
overwriting the existing file. 

WARNING: Do not modify your event file using any program other than Mindful, otherwise it may become 
unusable. 

See also Setting a different event file for each user



Setting a different event file for each user

By default, Mindful saves your list of events in a file called Mindful.bin located in the folder where Mindful 
was installed. This works perfectly if there is only one user logged in at any time and the event list is the 
same for all users of the computer on which Mindful is installed. 

However, the event file is not a shareable database and each user should have their own separate event 
file if they don’t want to share the same list of events with the other users of the same computer and 
avoid stepping on each other’s toes with their respective events so to speak. 

For each user to have their own copy of the event file, each user should save the file in a different location
using the File -> Save As… command.

For example, if there are two users on your computer called Mary and Paul respectively, then Mary could 
save the event file as ‘C:\Documents and Settings\Mary\My Documents\Mindful.bin’ and Paul could save 
the event file as ‘C:\Documents and Settings\Paul\My Documents\Mindful.bin’ while logged into their 
respective account. By doing so, Mindful remembers where each user has saved their respective file and 
opens each user’s respective file when they log into their respective account, allowing each user to keep 
a separate set of events.

NOTE: Mindful remembers only the location of the event file specified the last time the File -> Save As… 
command was issued for each user.

See also Backing up your event file, Renaming your event file, The Event File



Changing the font color and style of events (Special Edition)

All events in Mindful are color-coded according to their point in time. By default, passed events appear in 
blue, current day events appear in bold red, events due for notice appear in orange and other future 
events appear in green in your list of events. 

If you are using Mindful SE, you can customize the font color and style of your events according to their 
point in time. To do so…

1. Select Application -> Preferences…
2. Select the Event List page of the Mindful Preferences dialog (if not already selected).
3. Under Event status, select the status of the events according to their point in time for which you want

a different font color and/or style.
4. Change the font color and/or style according to your preference (see the result of your changes in 

the Sample list view on the right side of the page).
5. Repeat steps 3 and 4 for each event status that you want to change.
6. Click OK or Apply to save your changes.

You can also change the background color of the event list by selecting a different color from the 
Background color list box located below the Sample list view.

See also Application Preferences dialog



Changing the alarm and countdown timer sounds (Special Edition)

By default, Mindful is installed with two sound files that are played when an alarm goes off and when the 
countdown timer reaches zero respectively. If you are using Mindful SE, you can change these sounds by
selecting different sound files. These sound files are Wave files, which should normally have a .wav 
extension.

To select different sound files to be played when an alarm goes off, the countdown timer reaches zero or 
both, do the following…

1. Select Application -> Preferences…
2. Select the Sounds page of the Mindful Preferences dialog.
3. Type the name and location of a sound file in the appropriate field for the sound that you want to 

change or click the Select sound file button located below the corresponding entry field to select a 
sound file through a file selection dialog.

4. Repeat step 3 for the other sound file if necessary.
5. Click OK or Apply to save your changes.

NOTE: You can use the Test sound file buttons located below each sound file entry to hear the sound of 
the file selected.

See also Application Preferences dialog



Checking for Updates

Mindful is a small application with big potential. As time goes by, new versions can be released with 
additional and/or improved features.

You can easily verify over the Internet whether new versions of Mindful have been released by selecting 
Application -> Check for updates.

You can also subscribe to our newsletter at http://www.felitec.com/newsletter.php to be informed 
automatically by email as new versions of Mindful and other Felitec products are released.



Uninstalling Mindful

To uninstall Mindful from your computer, select Start -> Programs -> Mindful -> Uninstall Mindful to launch
Mindful’s removal program and follow its instructions.



About Events

There are two kinds of events in Mindful; those that you define yourself and those that have been 
predefined. Mindful gives you a choice of 72 predefined yearly events including many US, Canadian and 
Jewish holidays. 

The predefined events are all recurring events. User-defined events can be one-time events like doctor 
appointments, or recurring events like anniversaries.

One-time events can be deleted automatically once the event is passed, or kept for future reference. For 
example, it may be useful to keep the date of your sight test so you can later recall when was the last time
you had it done. Recurring events will continue to exist until deleted manually.

When a one-time event kept for future reference is passed, the number of days left for that event will 
appear as negative in your list of events. A negative number of days represents the number of days since 
the event passed. For example, if an event has minus 3 (-3) days left, this means that the event occurred 
3 days ago. 

A user-defined event can be simple like an anniversary, which occurs on the same date every year, or 
formulated, like a meeting that occurs every 3 months on the last Friday of the month.

When creating an event for an anniversary, you can include the age (in years) of the original event by 
specifying its year of origin between square brackets in the description. For example, if John is born in 
1980 and the current year is 2005, setting the event description to “John's [1980] Birthday” will appear as 
“John's 25th Birthday” in the list of events. We have included a concrete example of this in the sample list 
of events with John Lennon's birthday. 

If you are using Mindful SE, your events have additional features not found in the standard edition... 

Ÿ Roll forward clearance is a feature that can stop your events from rolling forward automatically until 
you manually clear them.

Ÿ Roll forward now is a feature that allows you to force the date of a recurring user-defined event to roll
forward to its next occurrence even though the event date has not yet passed.

Ÿ Alarms allow you to have specific actions performed at a precise time on the day of the event. 

For more information on how to manage events, see Clearing/Unclearing events, Rolling events forward, 
Creating Events, Modifying Events and Deleting Events.

See also Mindful versus Mindful SE



About Alarms (Special Edition)

Each event has an alarm that can be turned on or off. When the alarm of an event is on, it can perform 
specific actions at a precise time on the day of the event. 

When it goes off, an alarm can display a popup window with (or without) a countdown timer for a preset 
number of minutes and/or execute a file or Internet link. A sound is also played when the alarm goes off 
and when the countdown timer (if applicable) reaches zero.

Popup windows
The popup window of an alarm can be handy to be reminded that it is time for you to do something. For 
example, if you are working at your computer all day, your alarms can remind you when it is time to take a
break. You can also set a countdown timer with the popup window of your alarm so you can tell how much
time is left in your break and when it ends.

Another example where the popup window with a countdown timer would be handy is for meetings. If you 
need a little time to prepare for a meeting, you can have an event with a name like ‘Meeting at 10:00am’ 
and an alarm set to go off at 9:45am with a 15-minute countdown timer. At 9:45am on the day of the 
meeting, the popup window will appear on your screen with the message ‘Meeting at 10:00am’ and the 
countdown timer would start counting down immediately for 15 minutes, letting you know in real time how 
much time is left before your meeting starts.

Executing a file or Internet link
In addition to (or instead of) displaying a popup window, each alarm can execute a file or Internet link. 

A file in this case can be any program or other file that has an association with a program. For example, if 
you need to update a spreadsheet once a week, you can have an event that will occur weekly with an 
alarm that will automatically start your spreadsheet program at a precise time on the day of that event. If 
your spreadsheet file itself has an extension associated with your spreadsheet program then you can 
have this file loaded into your spreadsheet program at the same time also. In this case, all you need to 
specify is the name and location of your spreadsheet file (e.g. C:\…\MySpreadsheet.xls).

An Internet link, also known as hyperlink, can be any valid URL (Uniform Resource Locator). Executing 
an Internet link when an alarm goes off can be useful for a number of situations. For example, to check if 
a deposit was made in your bank account on a certain date, you can set a link to your bank’s web site 
(e.g. http://www.yourbank.com) and be that much closer to checking if the deposit was made at the time 
the event alarm goes off. 

An Internet link may also be useful to send an email to a friend or relative on their anniversary. For 
example, the link ‘mailto:John Smith <jsmith@yahoo.com>?subject=Happy Birthday&Body=Have a great 
one!’ should start a new email in your default email client and set ‘John Smith’ with his email address as 
the recipient, ‘Happy Birthday’ as the subject, and ‘Have a great one!’ as the text of the email ready for 
you to modify and/or send right away. 



The Event Details dialog

Event Details dialog (first page)

The event details dialog is a wizard that guides you through the creation or modification of events. This 
dialog has many pages and the number of pages used for creating or modifying a specific event depends 
on the details of that event. For example, fewer pages are used to create an event that you pick from the 
drop-down list of predefined events because you don’t have to specify when the next time the event will 
occur.

You don’t have to know which pages are used when creating or modifying an event. Simply follow the 
instructions on one page and then click the ‘Next’ button to go to the next page. Mindful determines itself 
which page comes next based on your entries on the previous page. 

The last page of the dialog is only to confirm your entries. From that page you can click Finish to create or
modify the event, or click Back to go back and apply any corrections to your entries. 



Mindful Preferences dialog (Special Edition)

The Mindful Preferences dialog, displayed by selecting Application  Preferences…, has two pages, the 
Event List page and the Sounds page. 

The Event List page allows you to change the background color of the event list as well as the font color 
and style of events displayed in the list according to their point in time.

The Sounds page allows you to select different sounds to be played when an alarm goes off or the 
countdown timer reaches zero.

For more information on how to change these preferences, please see Changing the font color and style 
of events and Changing the alarm and countdown timer sounds.



The Event File

Originally, the file that stores your list of events in Mindful is called Mindful.bin and is located in the folder 
where Mindful was installed. The event file can be saved under a different name and/or location using the 
File -> Save As… command. This file has a proprietary format and should not be modified by any 
program other than Mindful itself. You need write access to this file in order to be able to save the 
changes applied to your list of events. 

The changes you make to your list of events are saved automatically when the program is closed or 
minimized and read again when the program starts. If you do not have write access to this file, you will 
receive an error message when the program attempts to save it. If this happens, simply select File -> 
Save As… to save the file in a different folder where you do have write access.

If Mindful is installed on a computer with many user accounts, it is recommended that each user saves 
their event file in a separate location using the File -> Save As… command. This has the advantage of 
allowing each user to have their own list of events and that the changes made by one user will not 
overwrite the changes made by another user when both users are logged on at the same time.

See also The List of Events, Renaming your Event File, Setting a different event file for each user



The List of Events

Event List (Special Edition)

Mindful is installed with a default list of events that you can modify to suit your needs. The purpose of the 
default list of events is to give you an idea of the kind of events you can create. Once you understand how
events work and how to create your own events, you probably want to delete the sample events and carry
on with your own.

The list of events is displayed automatically when the program starts and at the beginning of a new day 
(assuming it contains some events due for notice) and remains displayed until you either hide, minimize 
or close the progam. When the program is minimized, you can restore the list of events by left-clicking the
Mindful icon in the system tray or right-clicking the icon and selecting Event List… from the popup menu. 
If your computer stays on overnight, your list of events is refreshed automatically at the beginning of each 
new day. After being refreshed, the list is displayed automatically if it contains one or more events due for 
notice.

In your list of events, you can view all the events, only the events due for notice, or only the current day 
events. A combo box on the tool bar located above the list of events allows you to select which events are
displayed in the list. For example, to show all events select the All events entry in the combo box.

NOTE: The dates in the list of events are shown according to the short date format as set in your 
Windows regional settings (control panel). To change the date format in Mindful, you simply have to 
change it in your Windows regional settings. Mindful will then use the new format the next time it displays 
your list of events.

To see the details of a particular event, simply position the mouse cursor over that event in the list for 
about one second and a hint will appear with all the details of that event. 

See also The Event File



The Event List Tool Bar

Event List Tool Bar (Special Edition)

The tool bar above the list of events has five speed buttons (three in the standard edition) and one combo
box. The five speed buttons allow you to clear/unclear, roll forward, create, modify and delete events 
respectively. The combo box allows you to select between displaying all events, events due for notice or 
today’s events only.

TIP: Speed buttons have hints that briefly describe their purpose. Simply position the mouse cursor over a
speed button in the program for about one second to see its purpose popup in a hint.

NOTE: The Clear/Unclear event and Roll event forward (first two) buttons do not exist in the standard 
edition of Mindful.

See also The Menu Bar



The Menu Bar

The main menu bar located at the top of Mindful’s main form has five menus named Application, File, 
Event, Tools and Help respectively.

The Application menu has four options described as follows…

Preferences* : To change the font color and style of events, and/or choose sounds for the 
alarms and the countdown timer. 

Check for updates : To verify over the Internet whether new versions of Mindful have been released.
Minimize : To minimize Mindful to the system tray
Exit : To close Mindful completely

The File menu currently has two options described as follows…

Save : To save your list of events to disk under its current name and location.
Save As : To save your list of events do disk under a different file name and/or location.

The Event menu has five options described as follows…

Clear/Unclear* : To clear (or unclear) the currently selected events.
Roll forward* : To roll forward** the event currently selected.
New : To add a new event to the list of events.
Modify : To modify the event currently selected.
Delete : To delete the events currently selected.

The Tools menu has three options described as follows…

Calendar : To display the mini calendar.
Date calculator* : To display the date calculator.
Countdown timer* : To display the countdown timer.

The Help menu has four options described as follows…

Getting started : To display the help topic on how to get started with Mindful.
Contents : To display the help file’s table of contents.
Web links : Various links to Felitec web site pages on the Internet.
About Mindful : To display the version number for the copy of Mindful currently installed on your 

computer, along with some copyright information.

* Mindful SE only
** Only recurring user-defined events that have been cleared can be rolled forward manually using this option. The 

option is disabled for all other events.    Only one event can be rolled forward at a time with this option.



The Status Bar

The status bar located at the bottom of Mindful’s main form (below the list of events) has two sections. 
The first section displays the current system date and time. The second section displays two numbers 
separated by a forward slash “/”. The first number is the number of days gone by in the current year, and 
the second number is the number of days left in the year. For example, 138/227 means that we are 
currently on the 138th day of the year and we still have 227 days to go before the year ends. These two 
numbers should add up to 365 unless the current year is a leap year.



The System Tray Icon

 When Mindful is running, the program icon is displayed in the system tray with all the other system tray 
icons. From this icon, you can see what is the next upcoming event on your list, restore your list of events 
(if it is minimized), display any of the tools (mini calendar, date calculator* or countdown timer*), or close 
Mindful completely.

If your computer remains on overnight, a balloon hint appears briefly above the Mindful icon in the system
tray when a new day starts (Windows 2000 and XP only). This is to inform you that your list of events has 
been refreshed (updated). You can click on the balloon hint to display your list of events and review the 
changes applied during the update. 

If after updating your list of events Mindful finds one or more events due for notice in it, the list is 
automatically displayed (i.e. you don’t have to click on the balloon hint) so you don't miss any event either
at the beginning of a new day or when you start your computer.

When you right-click the Mindful icon in the system tray, a popup menu is displayed. 

To restore (display) your list of events manually, simply left-click the icon in the system tray, or right-click 
the icon and then select Event List… from the popup menu.

To display the mini calendar, right-click the icon in the system tray and then select Calendar… from the 
popup menu. 

To display the date calculator*, right-click the icon in the system tray and then select Date calculator… 
from the popup menu. 

To display the countdown timer*, right-click the icon in the system tray and then select Countdown timer…
from the popup menu. 

You can see what is the next upcoming event on your list by positioning the mouse cursor over the 
Mindful icon in the system tray and holding it there for about half a second. Mindful then displays your 
next upcoming event in a hint.

To close Mindful from the system tray icon, right-click the icon and then select Close Mindful from the 
popup menu.

* Mindful SE only



Glossary of Terms

Following is a list of common (or not so common) terms used in Mindful. Simply click on a term to see its 
definition.

Auto-clear flag
Cleared event
Event due for notice
Freeware
Predefined event
Roll forward
System tray
User-defined event



Contact and Support

We hope that you will find the answer to most of your questions in this help file. However, if you have any 
other questions, comments and/or suggestions about Mindful, please do not hesitate to visit our contact 
page online at http://www.felitec.com/contact.html. 



License Agreement

The complete License Agreement for this edition of Mindful is found in the file License.txt installed with the
program.



Auto-clear Flag (Special Edition)
A flag that determines whether an event is cleared automatically after being created and each time it is 
rolled forward. The auto-clear flag is set by checking the Auto-clear check box during the creation or 
modification of an event. 



Cleared Event (Special Edition)
An event can be either cleared or non-cleared. An event has to be cleared before it can be rolled forward 
to its next occurrence (recurring event) or deleted (one-time event) automatically by the program when its 
occurrence date has passed. User-defined recurring events also need to be cleared before they can be 
rolled forward manually.

NOTE: In the standard edition of Mindful, all events are cleared automatically and the status of an event 
(i.e. cleared/non-cleared) cannot be changed.



Event Due for Notice
An event is due for notice when the number of days left until that event occurs is less than or equal to the 
number of days notice set for that event. For example, if the number of days left until an event occurs is 7 
and the number of days notice is 15 then this event is due for notice (7 <= 15).



Freeware
A software program that you have the right to use at no cost.



Predefined Event
An event that you pick from a list and over which you have limited control (i.e. you have no control over its
name or occurrence date). For example, Fathers’ day, Labor day, Easter Sunday, etc. Compare with user-
defined event.



Roll Forward
Action of changing the date of an event to its next occurrence. An event can be rolled forward 
automatically when its current occurrence date is passed. User-defined events can also be rolled forward 
manually (Special Edition) before their current occurrence date has passed. In either case, an event must 
first be cleared before it can be rolled forward.



System Tray
The box in the lower right-hand corner of your computer screen which contains icons of various programs 
that are always running in the background, including your anti-virus software, the clock, and other utilities.



User-defined Event
A user-defined event is an event that you define yourself (i.e. you determine the name of the event and 
when it occurs) like the anniversary of a friend, an appointment with your doctor, or the time to pay your 
rent. Compare with predefined event.




